Project

General

Profile

display doesn't work, laser doesn't cut drawings.

Added by FablabZuidlimburg over 7 years ago

Onze Laos /HPC lasersnijder laat op dit moment niets op de display zien en wil geen bestanden snijden. Ik hoop dat jullie ons weer op de goede weg kunnen helpen. Zowel het display als de lasersnijder hebben het voorheen wel goed gedaan.

Op dit moment staat er op de mbed:
laoslaser-14-9-2012.bin
Mbed.htm
en de onderstaande config

de laser homed wel en als we op de knop lasertest drukken brandt hij ook een gaatje.
We meten bij de display wel 5 volt maar de backlight licht niet op en er is niets op de display te zien. We hebben in de config zowel
sys.nodisplay 1 als sys.nodisplay 0 geprobeerd.
iedere keer als we de bestanden op de mbed veranderd hebben, hebben we de mbed eerst geformatteerd, op het knopje gedrukt voor de mbed.htm en vervolgens de firmware en config erop gezet.

Hoe krijgen we het display en het snijden weer aan de praat?

Config file for HPC laser LS-3020
;
; for the version with flatcable and 26x32 honeycomb
; as distributed in may 2012
;
; configuration made by Jaap Vermaas <>
;
; Save on MBED in the root, as "config.txt"
;
net.ip 192.168.1.111 ; IP address [xxx.xxx.xxx.xxx]
net.netmask 255.255.255.0 ; netmask [xxx.xxx.xxx.xxx]
net.gateway 192.168.1.1 ; gateway
net.dns 192.168.1.194 ; DNS server
net.dhcp 0 ; Enable DHCP for IP address [0/1]
net.port 69 ; Communication socket port number []

sys.debug 1 ; debug flags bit0=verbose,
; bit1=log to serial, bit2=log to file
sys.autohome 1 ; Enable automatic homing at startup [1/0]
;(or wait for cover to close)
sys.nodisplay 1 ; Disable the display [1/0]
sys.i2cbaud 0 ; I2C display baudrate [Hz]

laser.enable 0 ; Laser enable signal polarity [0/1]
laser.on 0 ; Laser on signal polarity [0/1]
laser.pwm.min 90 ; minimum pwm value [%]
laser.pwm.max 0 ; maximum pwm value [%]
laser.pwm.freq 1000 ; pwm frequency [Hz]

motion.enable 0 ; Enable signal state to enable motors [0/1]
motion.homespeed 50 ; Homing speed [mm/sec]
motion.speed 50 ; max linear speed [mm/sec]
motion.accel 500 ; linear acceleration [mm/sec2]
motion.tolerance 100 ; tolerance [1/1000 units]

; old firmware: set speed in [usec]
motion.highspeed 100 ; speed in [usec]

; Next values are valid for axis x,y,z and e
x.pol 0 ; home/limit sensor polarity [1/0]
;x.scale 158516 ; axis scaling [steps/meter]
x.scale 79258
; use negative number to invert direction [1/0]
x.homedir 1 ; state of the direction signal when homing
x.home 400000 ; home positions [um]
x.min 0 ; minimal position [um]
x.max 300000 ; maximum position [um]
x.rest 300000 ; rest position [um]
x.speed 1000 ; maximum speed [mm/sec]
x.invert 0 ; Invert signal polarity for step signal [1/0]

; Now for the Y-axis:
y.pol 0 ; home/limit sensor polarity [1/0]
;y.scale 158516 ; axis scaling [steps/meter]
y.scale 79258
; use negative number to invert direction [1/0]
y.homedir 1 ; state of the direction signal when homing
y.home 205000 ; home positions [um]
y.min 0 ; minimal position [um]
y.max 200000 ; maximum position [um]
y.rest 200000 ; rest position [um]
y.speed 1000 ; maximum speed [mm/sec]
y.invert 0 ; Invert signal polarity for step signal [1/0]

; Z-axis not in use for HPC
; z.min 0
; z.max 200000
; z.home 100000


Replies (4)

RE: display doesn't work, laser doesn't cut drawings. - Added by jaap over 7 years ago

Als je

sys.nodisplay 1

in de configfile hebt staan én het display hebt losgekoppeld, zou de laser gewoon moeten werken als je er een file heen stuurt. Werkt dat wel? Zo niet, is er meer aan de hand dan een kapot display.

Je kan een USB kabel aansluiten op de MBED (mini-usb) en een serial terminal openen, dan krijg je ook debug-informatie. Ik denk dat je 115200 als baudrate moet hebben.

RE: display doesn't work, laser doesn't cut drawings. - Added by FablabZuidlimburg over 7 years ago

Bedankt, het niet snijden was een netwerk instellingen foutje. Hij snijdt nu weer als ik sysnodisplay 1 heb staan. Het maakt dan niet uit of ik het display wel of niet verbonden heb. Het display werkt echter nog niet. Als ik sysnodisplay 0 heb staan homed hij niet meer. Ik weet niet hoe ik een serial terminal kan openen maar misschien weet onze nieuwe vrijwilliger dat. We gaan er dan morgen of volgende week mee verder.

RE: display doesn't work, laser doesn't cut drawings. - Added by FablabZuidlimburg about 7 years ago

Hoi Allemaal, Kees, onze nieuwe vrijwilliger is er mee bezig geweest. Als ik het goed begrepen heb vond hij geen debug informatie. Hij heeft eerst de communicatie tussen PC en het Arduino Uno bordje aan de praat gekregen en vervolgens met negatief resultaat geprobeerd om de file
lasercutterpanelv0_3.pde in de test mode met behulp van het Arduino bordje als ISP programmer in de Atmel 168 van het display bordje te laden.
Dat gaf een foutmelding, en ook reageerde het display bordje niet zoals zou moeten in test mode. (gewoon geen enkele reactie als je de voedingsspanning er op zette.)

Wij weten niet meer verder. Zouden we het display misschien op kunnen sturen naar iemand met een werkend display? Dan weten we of het aan de display ligt of dat het probleem ergens anders ligt.

RE: display doesn't work, laser doesn't cut drawings. - Added by hugomeiland almost 7 years ago

Hoi Fablab,

het is al een tijdje stil op deze thread; zijn jullie al verder gekomen of kunnen jullie nog hulp gebruiken?

Laat maar horen!

Hugo

    (1-4/4)