i2c display atmega won't program twice

Added by alan almost 8 years ago

Once I realised that my atmega chip had a missing (or corrupt?) sketch programmed in I obtained a very cheap usb to ttl serial programmer (£1.88!) on ebay and succesfully uploaded the sketch (with debug set) and all went fine and it works perfectly. However I cannot now reprogram it with debug=0! I do not have the rts pin on my adapter which I guess pulses the reset pin?
I have tried manually holding reset low at various times and ways to no avail.

I have also tried reloading the bootloaded but am not sure if I need to change the arduino ide settings first

Any help will be much appreciated!

Replies (2)

RE: i2c display atmega won't program twice - Added by jaap almost 8 years ago

Hi Alan,

I had the same problem a couple of times, sometimes even with a batch of ATmega 168 chips. Flashing a new bootloader into the chip solved the problem, but then you need special hardware to do so.

After trying many times, I usually got them so far as to accept a new program anyway.

To install a new bootloader: If you have an Arduino, you can use that as an ISP to flash a new bootloader in the chip: