Project

General

Profile

Bug #68

Pololu Ground problem on Rev 4 boards

Added by jaap almost 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Mainboard
Target version:
Start date:
2013-01-05
Due date:
% Done:

0%


Description

There is a problem with (all?) Rev4 boards: GND on three of the 4 Pololu's is not connected to the main GND of the board. This is a severe problem and it can blow up your MBED or Pololu!

Still need to find out where in the production process this went wrong and if it applies to all Rev4 boards.

To check if your board has this problem, chek if there is connection between GND of the Pololu's X,Y and E and the GND of the power connector. If not, connect it, for example by making a bridge on the backside between the Pololu GND of the E-Axis and the GND pin of capacitor C3 (near the power connection).

rev4bug.jpg View (92.7 KB) jaap, 2013-01-05 22:50

rev4solderfix.JPG View - Rev 4 Solder Fix (3.03 MB) DeanoC, 2013-02-24 16:16

History

#1 Updated by jaap almost 5 years ago

The bug is in all Rev4 boards. There is missing connection between the lowest Pololu (Extruder) GND and the GND surface of the GND solder pad next to it (J35).

The missing connection is the only connection between power GND and GND for the lower three Pololu's! It does not only affect the extruder Pololu, but all three.

Since the extruder Pololu is not needed for (most) lasers, you can simply solve the problem by connecting a small wire from the Pololu GND hole to the solder pad.

I hope the attached picture clarifies what you need to do.

#2 Updated by DeanoC almost 5 years ago

Hires photo of the solder fix we used while building our Laos main board.
Rev 4 Solder Fix

#3 Updated by peter about 4 years ago

  • Status changed from New to In Progress

#4 Updated by peteruithoven over 3 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF